您尚未登录。

楼主 # 2023-12-27 11:03:52

chaplin1999
会员
注册时间: 2019-11-08
已发帖子: 40
积分: 39.5

D133 烧录经常失败,怎么解决

自己画的开发板 D133 目前只使用了一路DCDC 3.3V  其他1.1,1.8V 使用内置1.jpg,已经在程序里配置。现在烧写程序。好几次才能成功一次,是不是使用单电源有bug,串口看日志,烧写失败时复位出现AAAA USB没连上.jpg几次都是这样 ,成功时 则是这样的.jpg

离线

#1 2023-12-27 11:28:14

sjshe3326
会员
注册时间: 2020-10-19
已发帖子: 123
积分: 67.5

Re: D133 烧录经常失败,怎么解决

看其他贴消息 好像需要boot里面先开启电源 然后才行。我一开始使用1.8V也是没电,可以下载没法运行。

离线

楼主 #2 2023-12-27 12:36:27

chaplin1999
会员
注册时间: 2019-11-08
已发帖子: 40
积分: 39.5

Re: D133 烧录经常失败,怎么解决

sjshe3326 说:

看其他贴消息 好像需要boot里面先开启电源 然后才行。我一开始使用1.8V也是没电,可以下载没法运行。

看上图 BOOT里也打开了内置电源

离线

#3 2023-12-27 14:02:04

sjshe3326
会员
注册时间: 2020-10-19
已发帖子: 123
积分: 67.5

Re: D133 烧录经常失败,怎么解决

你这个是 编译内核和应用的 menuconfig里的把。 使用的boot好像是个bin,需要把哪个boot的bin重新做个。

参考 :


我的是只用了3.3V供电,其他的是用的内置的ldo电源,用的nor flash。根据官方的说法要先把config配置成bootloader,然后在bootloader的menuconfig中把1.1和1.8的电源使能输出(默认1.1有1.2V输出,1.8没有输出),根据手册1.1V和1.8V的寄存器值应设为4和3,然后编译;接下来把config配置成app的,同理配置1.1和1.8电源后再编译,按他们的说法打包镜像的时候会自动去找前面编译好的bootloader一起打包。
举个例子:
在luban-lite下使用env:scons --apply-def=2 ---> scons --menuconfig配置ldo输出 --->编译;scons --apply-def=3 ---> scons --menuconfig配置ldo输出 --->编译,然后就可以烧录镜像了

最近编辑记录 sjshe3326 (2023-12-27 14:08:55)

离线

#4 2023-12-27 21:50:59

tangloong
会员
注册时间: 2023-04-11
已发帖子: 212
积分: 191

Re: D133 烧录经常失败,怎么解决

我也发现了 之前的板子好好的,镜像也好好的,也出现烧录不了   有的镜像可以 有的不行;烧录跟镜像还有关系
我还有两块板子 1.8V异常  也很诡异

离线

#5 2023-12-29 13:42:48

ArtInChip
会员
注册时间: 2023-11-11
已发帖子: 162
积分: 168

Re: D133 烧录经常失败,怎么解决

tangloong 说:

我也发现了 之前的板子好好的,镜像也好好的,也出现烧录不了   有的镜像可以 有的不行;烧录跟镜像还有关系
我还有两块板子 1.8V异常  也很诡异

原理图发到群工程师帮你看看。

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn