WhyCan Forum(哇酷开发者社区)

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn

您尚未登录。

#1 2020-11-04 20:13:27

ocean
会员
注册时间: 2020-11-01
累计积分: 10

licheepi v3s 4.10 内核 有线网口无法驱动

1.在4.14 内核中,v3s的有线网口能工作。
2.因为 驱动关系,v3s 外接了一个 无线网卡,该无线网卡 的驱动只能在4.10 下编译通过,所以就限制了我只能用4.10的内核。
3. 但是找了很多资料,发现驱动licheepi网口都是在4.14下使用,或者4.12下

有没有在4.10下的驱动licheepi网口的资料或者方法,谢谢各位。

离线

#2 2020-11-05 10:08:37

孤星泪
会员
注册时间: 2020-03-18
累计积分: 194

Re: licheepi v3s 4.10 内核 有线网口无法驱动

我们都跑最新长支持版本5.4.77了,你还在纠结linux4.10

离线

#3 2020-11-05 16:02:04

ocean
会员
注册时间: 2020-11-01
累计积分: 10

Re: licheepi v3s 4.10 内核 有线网口无法驱动

感谢各位,wifi驱动找到方法在4.14上跑了,现在换成4.14,有线已经没问题了

离线

#4 2020-11-05 16:54:13

Pratik
会员
注册时间: 2020-04-08
累计积分: 9

Re: licheepi v3s 4.10 内核 有线网口无法驱动

Hi Ocean,

Can you please help me to run wireless network in 4.14 kernel.?

Actually I have build the esp8089.ko but i can not scan any network.

Can you please help me.

Regards,
Pratik

离线

#5 2020-11-05 17:02:27

孤星泪
会员
注册时间: 2020-03-18
累计积分: 194

Re: licheepi v3s 4.10 内核 有线网口无法驱动

前面有个帖子不是有固件嘛,你先烧进去看能不能跑,确定硬件有没有问题。

离线

#6 2020-11-05 17:21:00

ocean
会员
注册时间: 2020-11-01
累计积分: 10

Re: licheepi v3s 4.10 内核 有线网口无法驱动

Pratik 说:

Hi Ocean,

Can you please help me to run wireless network in 4.14 kernel.?

Actually I have build the esp8089.ko but i can not scan any network.

Can you please help me.

Regards,
Pratik


Hi Pratik,
Sorry, I am using another wireless network card, I don’t know about esp8089

离线

#7 2020-11-06 15:09:10

hanzixi_angel
会员
注册时间: 2020-09-21
累计积分: 24

Re: licheepi v3s 4.10 内核 有线网口无法驱动

ocean 说:

1.在4.14 内核中,v3s的有线网口能工作。
2.因为 驱动关系,v3s 外接了一个 无线网卡,该无线网卡 的驱动只能在4.10 下编译通过,所以就限制了我只能用4.10的内核。
3. 但是找了很多资料,发现驱动licheepi网口都是在4.14下使用,或者4.12下

有没有在4.10下的驱动licheepi网口的资料或者方法,谢谢各位。



5.2.y打开配置就可以使用以太网了   4.10还是不建议用了   我踩到不少坑

最近编辑记录 hanzixi_angel (2020-11-06 15:09:37)

离线

#8 2020-11-09 00:49:16

ocean
会员
注册时间: 2020-11-01
累计积分: 10

Re: licheepi v3s 4.10 内核 有线网口无法驱动

hanzixi_angel 说:
ocean 说:

1.在4.14 内核中,v3s的有线网口能工作。
2.因为 驱动关系,v3s 外接了一个 无线网卡,该无线网卡 的驱动只能在4.10 下编译通过,所以就限制了我只能用4.10的内核。
3. 但是找了很多资料,发现驱动licheepi网口都是在4.14下使用,或者4.12下

有没有在4.10下的驱动licheepi网口的资料或者方法,谢谢各位。



5.2.y打开配置就可以使用以太网了   4.10还是不建议用了   我踩到不少坑

因为 我需要驱动一款网卡,这款的网卡的驱动,目前最高只能在4.10上运行,更高版本的kernel,一部分无线接口换了,需要移植,但是网卡驱动这种东西,看了下,要移植到4.14需要动一堆东西,不敢随便动。
目前的问题是 4.10 下这个网卡可以驱动,但是有线跑不起来,很蛋疼

离线

#9 2020-11-09 14:29:30

hanzixi_angel
会员
注册时间: 2020-09-21
累计积分: 24

Re: licheepi v3s 4.10 内核 有线网口无法驱动

ocean 说:
hanzixi_angel 说:
ocean 说:

1.在4.14 内核中,v3s的有线网口能工作。
2.因为 驱动关系,v3s 外接了一个 无线网卡,该无线网卡 的驱动只能在4.10 下编译通过,所以就限制了我只能用4.10的内核。
3. 但是找了很多资料,发现驱动licheepi网口都是在4.14下使用,或者4.12下

有没有在4.10下的驱动licheepi网口的资料或者方法,谢谢各位。



5.2.y打开配置就可以使用以太网了   4.10还是不建议用了   我踩到不少坑

因为 我需要驱动一款网卡,这款的网卡的驱动,目前最高只能在4.10上运行,更高版本的kernel,一部分无线接口换了,需要移植,但是网卡驱动这种东西,看了下,要移植到4.14需要动一堆东西,不敢随便动。
目前的问题是 4.10 下这个网卡可以驱动,但是有线跑不起来,很蛋疼



你是无线网卡吗?  有些接口确实变了 编译会报错   自带的以太网驱动我用的是5.2.y  可以直接用

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB