您尚未登录。

#1 2020-12-22 10:35:22

L_max
会员
注册时间: 2020-12-08
累计积分: 33

f1c100s的uboot添加以下选项内核启动不了?

TF启动
uboot:u-boot-nano-lcd800480
Linux:linux-nano-5.2-tf

U-boot只要勾选 Enable graphical uboot console on HDMI, LCD or VGA ,内核就启动不了,去掉就能正常启动,这是什么原因啊

ARM architecture  ---> 

      [勾选] Enable graphical uboot console on HDMI, LCD or VGA 

启动logo

U-Boot SPL 2018.01 (Dec 22 2020 - 10:23:57)
DRAM: 32 MiB
Trying to boot from MMC1


U-Boot 2018.01 (Dec 22 2020 - 10:23:57 +0800) Allwinner Technology

CPU:   Allwinner F Series (SUNIV)
Model: Lichee Pi Nano
DRAM:  32 MiB
MMC:   SUNXI SD/MMC: 0
*** Warning - bad CRC, using default environment

Setting up a 8x272 lcd console (overscan 0x0)
In:    serial@1c25000
Out:   serial@1c25000
Err:   serial@1c25000
Net:   No ethernet found.
starting USB...
No controllers found
Hit any key to stop autoboot:  0 
reading zImage
4682720 bytes read in 238 ms (18.8 MiB/s)
reading suniv-f1c100s-licheepi-nano.dtb
6545 bytes read in 25 ms (254.9 KiB/s)
## Flattened Device Tree blob at 80c00000
   Booting using the fdt blob at 0x80c00000
   Loading Device Tree to 80e27000, end 80e2b990 ... OK

Starting kernel ...

离线

#2 2021-02-09 19:20:37

1053dd
会员
注册时间: 2021-01-28
累计积分: 2

Re: f1c100s的uboot添加以下选项内核启动不了?

我也是同样的问题,而且如果不插串口的话,uboot也进不去,莫名其妙的

离线

#3 2021-02-10 00:35:41

sea18c
会员
注册时间: 2019-08-05
累计积分: 222

Re: f1c100s的uboot添加以下选项内核启动不了?

有可能供电不足吗?

离线

#4 2021-02-10 10:12:45

1053dd
会员
注册时间: 2021-01-28
累计积分: 2

Re: f1c100s的uboot添加以下选项内核启动不了?

sea18c 说:

有可能供电不足吗?

不是的,用的5V 2.5A电源,功耗肯定够的

离线

#5 2021-02-10 10:36:57

路人甲
会员
注册时间: 2017-09-07
累计积分: 196

Re: f1c100s的uboot添加以下选项内核启动不了?

1053dd 说:
sea18c 说:

有可能供电不足吗?

不是的,用的5V 2.5A电源,功耗肯定够的

Enable graphical uboot console on HDMI, LCD or VGA

这个是不是 控制台导向 framebuffer (/dev/fb0) ?

离线

#6 2021-02-10 11:33:02

1053dd
会员
注册时间: 2021-01-28
累计积分: 2

Re: f1c100s的uboot添加以下选项内核启动不了?

路人甲 说:
1053dd 说:
sea18c 说:

有可能供电不足吗?

不是的,用的5V 2.5A电源,功耗肯定够的

Enable graphical uboot console on HDMI, LCD or VGA

这个是不是 控制台导向 framebuffer (/dev/fb0) ?

刚才试了下把uboot 里的suniv.h 里的LOGO屏蔽掉就能进内核了,

#define CONFIG_VIDEO_LOGO
/*#define CONFIG_VIDEO_BMP_LOGO*/

我怀疑是licheepi 加的这个logo的代码块的位置是不是不对,因为启动的时候设备树的   
Loading Device Tree to 80e61000, end 80e65f36 ... OK 这句话,
在加logo和不加logo的时候不一样。

顺便问一下怎么看
Enable graphical uboot console on HDMI, LCD or VGA
这个是不是 控制台导向 framebuffer (/dev/fb0) ,我刚入门,还不太懂,我看我的启动log里有
[    1.489293] sun4i-drm display-engine: fb0:  frame buffer device这句话

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn