您尚未登录。

楼主 # 2023-02-20 16:11:23

lmjlzyljy
会员
注册时间: 2021-10-17
已发帖子: 9
积分: 11

V3S spi-nand 更换导致的烧录错误,请各位大佬指点一二。

原来的V3s板子搭载spi-nand 芯片是MX35LF1GE4AB-Z4ITR(128M),由于需要安装了QT的库比较多,容量不够使用。因此新买了MX35LF2GE4AD-Z4I(256M),硬件更换完后上电烧入原来的固件,出现如下错误:
fes commit : 8
beign to init dram
DRAM DRIVE INFO: V0.7
DRAM Type = 2 (2:DDR2,3:DDR3,6:LPDDR2,7:LPDDR3)
DRAM CLK = 360 MHz
DRAM zq value: 000039bb
DRAM size = 64 MB
init dram ok
[      2.769]

U-Boot 2011.09-rc1 (Feb 20 2023 - 09:54:10) Allwinner Technology

[      2.777]version: 1.1.0
[      2.779]uboot commit : 8
[      2.786]pmbus:   ready
not set main pmu id
axp_probe error
[      2.792]PMU: pll1 408 Mhz,PLL6=600 Mhz
AXI=204 Mhz,AHB=204 Mhz, APB1=102 Mhz
set power on vol to default
dcdc2_vol = 1200
axp set dcdc2_vol to 1200 failed
dcdc3_vol = 3300
axp set dcdc3_vol to 3300 failed
aldo2_vol = 2500
axp set aldo2_vol to 2500 failed
aldo3_vol = 3000
axp set aldo3_vol to 3000 failed
ldo1_vol = 3300
axp set ldo1_vol to 3300 failed
ldo2_vol = 3000
axp set ldo2_vol to 3000 failed
ldo3_vol = 3000
axp set ldo3_vol to 3000 failed
find power_sply to end
vbus exist
no battery, limit to dc
dram_para_set start
dram_para_set end
[      2.921]DRAM:  64 MiB
relocation Offset is: 0309c000
save config for small mem_size
workmode = 16
storage type = 0
NAND_UbootProbe start
NB1 : enter phy init
NandHwInit: Start Nand Hardware initializing .....
uboot:nand version: 2 25 20150917 1145
Reg 0x01c20848: 0x3333
Reg 0x01c2085c: 0x55
Reg 0x01c20864: 0x10
uboot nand_request_tx_dma: reqest genernal dma for nand success, 0x43a31cd0
request general tx dma channel ok!
uboot nand_request_tx_dma: reqest genernal dma for nand success, 0x43a31cec
request general rx dma channel ok!
SPI nand ID: 326c2 326c2
_SearchNandArchi fail
[ERR]NandHwInit: SCN_AnalyzeNandSystem() failed!
NandHwInit: End Nand Hardware initializing ..... FAIL!
NB1 : nand phy init fail
NB1 : enter phy Exit
nand release dma:43a31cd0
nand release dma:0
NAND_UbootProbe end: 0xffffffff
try nand fail
board_mmc_init start
[      3.084][mmc]: mmc driver ver 2015-04-13 14:50:00
err: gpio count < =0 ,gpio_count is: 0
[      3.093][mmc]: get sdc_phy_wipe fail.
[      3.096][mmc]: get sdc0 sdc_erase fail.
[      3.100][mmc]: get sdc_2xmode fail  used =  0
[      3.105][mmc]: get sdc_ddrmode fail  used =  0
[      3.109][mmc]: get sdc_f_max fail,use default  50000000Hz
[      3.115][mmc]: get card_line fail,use default card_line 4
[      3.121][mmc]: get sdc_ex_dly_used fail,use default
board_mmc_init end
[      3.127][mmc]: SUNXI SD/MMC: 2
[      3.139][mmc]: *Try SD card 2*
[      3.142][mmc]: mmc 2 cmd 8 err 2
[      5.144][mmc]: mmc 2,update clk failed
[      5.147][mmc]: mmc send if cond failed
[      5.154][mmc]: mmc 2 cmd 55 err ffffffff
[      5.160][mmc]: send app cmd failed
[      5.163][mmc]: *Try MMC card 2*
[      5.170][mmc]: mmc 2 cmd 1 err 2
[      7.171][mmc]: mmc 2,update clk failed
[      7.174][mmc]: mmc send op cond failed
[      7.178][mmc]: Card did not respond to voltage select!
[      7.183][mmc]: ***SD/MMC 2 init error!!!***
[      7.188][mmc]: erase_grp_size:0x0WrBlk * 0x0 = 0x0 Byte
[      7.193][mmc]: secure_feature 0x0
[      7.197][mmc]: secure_removal_type  0x0
MMC init failed
MMC:   board_mmc_init start
[      7.205][mmc]: mmc driver ver 2015-04-13 14:50:00
[      7.209][mmc]: get sdc_phy_wipe fail.
[      7.213][mmc]: get sdc0 sdc_erase fail.
[      7.217][mmc]: get sdc_f_max fail,use default 50000000Hz
[      7.223][mmc]: get sdc_ex_dly_used fail,use default dly
board_mmc_init end
[      7.230][mmc]: SUNXI SD/MMC: 2, [      7.233][mmc]: SUNXI SD/MMC: 0
In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
mbr not exist
Net:   eth0Warning: failed to set MAC address

[      7.249]Hit any key to stop autoboot:  0
work mode=0x10
run usb efex
buf queue page size = 2048
delay time 2500
usb init ok
set address 0x40
set address 0x4
SUNXI_EFEX_ERASE_TAG
erase_flag = 0x1
FEX_CMD_fes_verify_status
FEX_CMD_fes_verify last err=0
the 0 mbr table is ok
the 1 mbr table is ok
the 2 mbr table is ok
the 3 mbr table is ok
*************MBR DUMP***************
total mbr part 6

part[0] name      :bootloader
part[0] classname :DISK
part[0] addrlo    :0x800
part[0] lenlo     :0x4000
part[0] user_type :32768
part[0] keydata   :0
part[0] ro        :0

part[1] name      :env
part[1] classname :DISK
part[1] addrlo    :0x4800
part[1] lenlo     :0x400
part[1] user_type :32768
part[1] keydata   :0
part[1] ro        :0

part[2] name      :boot
part[2] classname :DISK
part[2] addrlo    :0x4c00
part[2] lenlo     :0x4000
part[2] user_type :32768
part[2] keydata   :0
part[2] ro        :0

part[3] name      :system
part[3] classname :DISK
part[3] addrlo    :0x8c00
part[3] lenlo     :0x2d000
part[3] user_type :32768
part[3] keydata   :0
part[3] ro        :0

part[4] name      :boot_logo
part[4] classname :DISK
part[4] addrlo    :0x35c00
part[4] lenlo     :0x100
part[4] user_type :32768
part[4] keydata   :0
part[4] ro        :0

part[5] name      :UDISK
part[5] classname :DISK
part[5] addrlo    :0x35d00
part[5] lenlo     :0x0
part[5] user_type :33024
part[5] keydata   :0
part[5] ro        :0

do need erase flash
no part need to protect user data
SUNXI_EFEX_MBR_TAG
mbr size = 0x10000
sunxi sprite init fail when downlaod mbr



请问各位应该从那方面入手解决?(我的板子是芯灵思的V3s开发板,用的SDK是uboot+bsp)

最近编辑记录 lmjlzyljy (2023-02-20 22:38:02)

离线

#1 2023-02-20 17:38:35

qinhao4832
会员
注册时间: 2020-07-22
已发帖子: 13
积分: 33

Re: V3S spi-nand 更换导致的烧录错误,请各位大佬指点一二。

我的F1C200S 也是差不多。 跑的是tina吗? 怎么uboot 是 2011的版本

离线

楼主 #2 2023-02-25 11:04:28

lmjlzyljy
会员
注册时间: 2021-10-17
已发帖子: 9
积分: 11

Re: V3S spi-nand 更换导致的烧录错误,请各位大佬指点一二。

市面上能买到的v3s开发板都是适配了128M spi-nand 或者就是TF卡启动。没有适配256M spi-nand 。请问有哪位高手适配过 MX35LF2GE4AD-Z4I(256M),指点迷津!!! 先谢谢了!

离线

#3 2023-02-28 10:39:33

hameyou
会员
注册时间: 2018-04-15
已发帖子: 169
积分: 6.5

Re: V3S spi-nand 更换导致的烧录错误,请各位大佬指点一二。

SPI nand ID: 326c2 326c2
_SearchNandArchi fail

这里测试提示搜寻Nand 失败,很明显换了256M spi-nand后,SPI nand ID变了。需要修改SPI nand ID驱动,增加这个型号才可以。

离线

楼主 #4 2023-03-11 17:12:12

lmjlzyljy
会员
注册时间: 2021-10-17
已发帖子: 9
积分: 11

Re: V3S spi-nand 更换导致的烧录错误,请各位大佬指点一二。

hameyou 说:

SPI nand ID: 326c2 326c2
_SearchNandArchi fail

这里测试提示搜寻Nand 失败,很明显换了256M spi-nand后,SPI nand ID变了。需要修改SPI nand ID驱动,增加这个型号才可以。

请问在那里修改?可否提供修改步骤?不胜感谢!!!

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn