WhyCan Forum(哇酷开发者社区)

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn

您尚未登录。

#1 2020-02-18 20:06:55

pythinker
会员
注册时间: 2019-02-12
累计积分: 186

Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

离线

#2 2020-02-18 20:09:34

pythinker
会员
注册时间: 2019-02-12
累计积分: 186

Re: Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

QQ截图20200218194020.png

QQ截图20200218194152.png

QQ截图20200218194506.png

QQ截图20200218194605.png

QQ截图20200218194830.png

QQ截图20200218194958.png

离线

#3 2020-05-01 08:24:43

起个名字好难
会员
注册时间: 2020-04-16
累计积分: 2

Re: Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

请问一下, 最后一个支持 Windows XP 的 Qt 是哪个版本呢?

离线

#4 2020-05-01 08:28:20

哇酷小二
管理员
注册时间: 2020-04-22
累计积分: 1,813

Re: Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

起个名字好难 说:

请问一下, 最后一个支持 Windows XP 的 Qt 是哪个版本呢?

https://stackoverflow.com/questions/50255414/is-it-possible-to-run-a-qt-5-10-programm-on-xp

支持XP的最新版本是 Qt 5.6.3。默认情况下,未启用 Windows XP 支持。您必须下载 Qt源代码并将其编译为 。这意味着,如果您安装 Qt 5.6.3(预构建)包,则 Windows XP 支持不会启用!您必须编译源代码。Qt 5.6.3 处于严格的阶段,如果要支持 Windows XP,则 Qt 5.6.3 处于严格阶段,并且可靠,Windows XP 仍安装在中国、印度等许多计算机上。./configure -target xp

Qt 5.6.3 向上兼容,支持 Windows XP、Windows Vista、Windows 7、Windows 8、Windows 10 的其他功能。

Qt 5.7 及以上不支持Windows XP。如果修改 PE-Header 使其运行,则应用程序可能会不时崩溃,因为 Windows API 需要 Windows XP 上不可用。

离线

#5 2020-05-05 20:25:39

hfpostxx
会员
注册时间: 2020-05-05
累计积分: 5

Re: Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

很久以前玩过qt,后来发现还是用c#开发比较快。

离线

#6 2020-09-12 09:31:30

明月照我沟渠
会员
注册时间: 2020-07-09
累计积分: 93

Re: Windows搭建当前 Qt4 最后一个版本 Qt4.8.7 +mingw 开发环境

很详细,跟着一步一步搞定了, 谢谢楼主 ^_^

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB