您尚未登录。

楼主 # 2021-10-14 09:43:49

llxoyhot
会员
注册时间: 2021-10-14
已发帖子: 1
积分: 1

A133芯片,配置龙芯Lt8911exb 问题

现在开机就显示一个小绿人,没有任何反应

如下是logo


[191]HELLO! SBOOT is starting!
[194]sboot commit : 7cc6792
[196]set pll start
[198]periph0 has been enabled
[201]set pll end
[203][pmu]: bus read error
[206]PMU: AXP803
[225]vaild para:1  select dram para0
[228]board init ok
[230]rtc[3] value = 0xa201
[253]try to probe rtc region
[255]DRAM BOOT DRIVE INFO: V0.40
[259]the chip id is 0x1400
[261]the chip id is 0x1400
[264]the chip id is 0x1400
[266]the chip id is 0x1400
[269]the chip id is 0x1400
[272]chip id check OK
[285]DRAM_VCC set to 1500 mv
[288]DRAM CLK =672 MHZ
[290]DRAM Type =3 (3:DDR3,4:DDR4,7:LPDDR3,8:LPDDR4)
[296]DRAM SIZE =1024 MBytes, para1 = 30fa, para2 = 4000000, dram_tpr13 = 7503
[303]dram_tpr11 = 100d0f0c,dram_tpr12 = 13121111
[309]DRAM simple test OK.
[312]chipid = 53001400
[314]nsi init ok 2020-4-7
[317][mmc]: mmc driver ver 2020-05-25 09:40-202007019516
[328][mmc]: Wrong media type 0x0
[331][mmc]: ***Try SD card 2***
[335][mmc]: mmc 2 cmd 8 timeout, err 100
[339][mmc]: mmc 2 cmd 8 err 100
[342][mmc]: mmc 2 send if cond failed
[346][mmc]: mmc 2 cmd 55 timeout, err 100
[350][mmc]: mmc 2 cmd 55 err 100
[354][mmc]: mmc 2 send app cmd failed
[357][mmc]: ***Try MMC card 2***
[383][mmc]: RMCA OK!
[385][mmc]: bias 4
[387][mmc]: mmc 2 bias 4
[390][mmc]: MMC 4.41
[392][mmc]: HSSDR52/SDR25 8 bit
[396][mmc]: 50000000 Hz
[398][mmc]: 14910 MB
[400][mmc]: ***SD/MMC 2 init OK!!!***
[430]read toc1 from emmc 32800 sector
[434]OLD version: 0.0
[436]NEW version: 0.0
[499]load rotpk hash
[548]load monitor-key hash
[551]load monitor hash
[709]set arisc reset to de-assert state
[762]load boot-key hash
[764]load boot hash
[815]load vbmeta-key hash
[818]load vbmeta hash
[870]load recovery-key hash
[873]load recovery hash
[876]monitor entry=0x48000000
[879]uboot entry=0x4a000000
[882]optee entry=0x48600000
[885]tunning data addr:0x4a0003e8
[888]run out of boot0
NOTICE:  BL3-1: v1.0(debug):5c8d955
NOTICE:  BL3-1: Built : 14:47:18, 2020-08-14
NOTICE:  BL3-1 commit: 8
NOTICE:  secure os exist
MESSAGE: [0x0] TEE-CORE: OP-TEE version: f37cc616 #1 Wed Jan 15 03:00:40 UTC 2020 arm
NOTICE:  BL3-1: Preparing for EL3 exit to normal world
NOTICE:  BL3-1: Next image address = 0x4a000000
NOTICE:  BL3-1: Next image spsr = 0x1d3

U-Boot 2018.05-g32d4b1a-dirty (Oct 14 2021 - 01:05:16 +0000) Allwinner Technology

[00.984]CPU:   Allwinner Family
[00.987]Model: sun50iw10
I2C:   ready
[01.111]DRAM:  1 GiB
[01.114]Relocation Offset is: 35f12000
[01.143]secure enable bit: 1
[01.148][ARISC ERROR] :get [allwinner,sunxi-hwspinlock] device node error
CACHE: Misaligned operation at range [7ffa6e30, 7ffa7148]
[SCP] :sunxi-arisc driver begin startup 2
[SCP] :0x1
[SCP] :arisc version: []
[SCP] :arisc startup ready
[SCP] :arisc startup notify message feedback
[SCP] :send hard sync feedback message: 0x900200
[SCP] :sunxi-arisc driver v1.10 is starting
[01.183]PMU: AXP803
[01.185]PMU: AXP803
bias_name:pc_bias        bias_vol:1800
[01.206]CPU=1008 MHz,PLL6=600 Mhz,AHB=200 Mhz, APB1=100Mhz  MBus=400Mhz
[01.213]drv_disp_init
request pwm success, pwm3:pwm3:0x300a000.
[LT8911EXB] : Lt8911exb_Resource_Init
[LT8911EXB] : vtotal = 1100, htotal = 2070, pixel_clk = 13662
[LT8911EXB] : get lt8911exb_power_io failed
[LT8911EXB] : Lt8911exb_Gpio_Init
[LT8911EXB] : --------Lt8911exb_Para_Dump-------
[LT8911EXB] : lt8911exb_2ic_addr        : 0x29
[LT8911EXB] : lt8911exb_mipi_lane       : 4
[LT8911EXB] : lt8911exb_edp_lane        : 2
[LT8911EXB] : lt8911exb_edp_bit         : 0
[LT8911EXB] : lt8911exb_edp_rate        : 1
[LT8911EXB] : lt8911exb_edp_pix         : 1
[LT8911EXB] : lt8911exb_hfp             : 44
[LT8911EXB] : lt8911exb_hs                      : 28
[LT8911EXB] : lt8911exb_hbp             : 78
[LT8911EXB] : lt8911exb_hact            : 1920
[LT8911EXB] : lt8911exb_htotal          : 2070
[LT8911EXB] : lt8911exb_vfp             : 2
[LT8911EXB] : lt8911exb_vs                      : 4
[LT8911EXB] : lt8911exb_vbp             : 14
[LT8911EXB] : lt8911exb_vact            : 1080
[LT8911EXB] : lt8911exb_pixel_clk       : 13662
[LT8911EXB] : lt8911exb-power           : dldo3
[LT8911EXB] : Lt8911exb_Init
[01.328]drv_disp_init finish
[01.333]gic: sec monitor mode
[01.336]flash init start
[01.338]workmode = 0,storage type = 2
[01.342][mmc]: mmc driver ver uboot2018:2020-5-25 9:26:00-202007011433
[01.349][mmc]: get sdc_type fail and use default host:tm4.
[01.361][mmc]: SUNXI SDMMC Controller Version:0x50300
[01.384][mmc]: Best spd md: 2-HSDDR52/DDR50, freq: 2-50000000, Bus width: 8
[01.391]sunxi flash init ok
[01.395]Loading Environment from SUNXI_FLASH... OK
[01.413]Item0 (Map) magic is bad
[01.415]the secure storage item0 copy0 magic is bad
[01.430]Item0 (Map) magic is bad
[01.432]the secure storage item0 copy1 magic is bad
[01.437]Item0 (Map) magic is bad
secure storage read widevine fail
[01.443]secure storage read widevine fail with:-1
secure storage read ec_key fail
[01.450]secure storage read ec_key fail with:-1
[01.456]usb burn from boot
delay time 0
weak:otg_phy_config
[01.466]usb prepare ok
[01.673]usb sof ok
[01.674]usb probe ok
[01.676]usb setup ok
set address 0x18
set address 0x18 ok
[04.683]do_burn_from_boot usb : have no handshake
[04.687]boot_gui_init:start
[04.692]set disp.dev2_output_type fail. using defval=0
[LT8911EXB] : Lt8911exb_Set_Power_Enable
[LT8911EXB] : Lt8911exb_Reset
[04.908]boot_gui_init:finish
[04.911]bmp_name=bootlogo.bmp
[04.923]soc ic_ver:0x0, qa_val:0x1, markid:0x53001400 dclk[0-9999]
[LT8911EXB] : Lt8911exb_Mipi_Convert_Edp_Init init start
[LT8911EXB] : Lt8911exb_Chipid_Check : chipid = 0x17-0x5-0xe0
[LT8911EXB] : Lt8911exb_Chipid_Check success
[LT8911EXB] : set pix mode 1920x1080
[LT8911EXB] : set bit mode 6 bit
[LT8911EXB] : set rate mode 2.7G
[LT8911EXB] : LT8911 tx pll locked
[LT8911EXB] : Read eDP EDID START......

,0x0,0xff,0xff,0xff,0xff,0xff,0xff,0x0,0xd,0xae,0xc4,0x15,0x0,0x0,0x0,0x0
,0x28,0x17,0x1,0x4,0x95,0x22,0x13,0x78,0x2,0xef,0x5,0x90,0x54,0x52,0x93,0x29
,0x25,0x50,0x54,0x0,0x0,0x0,0x1,0x1,0x1,0x1,0x1,0x1,0x1,0x1,0x1,0x1
,0x1,0x1,0x1,0x1,0x1,0x1,0x5e,0x35,0x80,0x96,0x70,0x38,0x14,0x40,0x2c,0x1c
,0x24,0x0,0x58,0xc1,0x10,0x0,0x0,0x18,0x0,0x0,0x0,0xfe,0x0,0x4e,0x31,0x35
,0x36,0x48,0x47,0x45,0x2d,0x45,0x41,0x42,0xa,0x20,0x0,0x0,0x0,0xfe,0x0,0x43
,0x4d,0x4e,0xa,0x20,0x20,0x20,0x20,0x20,0x20,0x20,0x20,0x20,0x0,0x0,0x0,0xfe
,0x0,0x4e,0x31,0x35,0x36,0x48,0x47,0x45,0x2d,0x45,0x41,0x42,0xa,0x20,0x0,0x1d[LT8911EXB] :
[LT8911EXB] : eDP Timing :
[LT8911EXB] : hfp : 44
[LT8911EXB] : hs : 28
[LT8911EXB] : hbp : 78
[LT8911EXB] : hact : 1920
[LT8911EXB] : htotal : 2070
[LT8911EXB] : vfp : 2
[LT8911EXB] : vs : 4
[LT8911EXB] : vbp : 14
[LT8911EXB] : vact : 1080
[LT8911EXB] : vtotal : 1100
[LT8911EXB] : pclk_10khz : 13662
[LT8911EXB] : Read eDP EDID END......
[LT8911EXB] : 0x2 small
[LT8911EXB] : H:0x0,M:0x1,L:0xa
[LT8911EXB] : DpcdValue = 0x0
[LT8911EXB] : link trian on going...
[LT8911EXB] : Link train success, 0x82 = 0x3e
[LT8911EXB] : panel link rate: 0xa
[LT8911EXB] : panel link count: 0x82
[LT8911EXB] : video check: mipi byteclk_r =  0x19152
[LT8911EXB] : video check: Vtotal =  0x44c
[LT8911EXB] : video check: Hact(word counter) = 0x780
[LT8911EXB] : video check: Vact = 0x438
[LT8911EXB] : Reg 0xD087 = 0x52
[LT8911EXB] : PCR Clock stable
[LT8911EXB] : Lt8911exb_Mipi_Convert_Edp_Init init success
4096056 bytes read in 2473 ms (1.6 MiB/s)
no support big size bmp[800x1280] on fb[1920x1080]
[07.396]show bmp FDT ERROR:fdt_get_all_pin:get property handle pinctrl-0 error:FDT_ERR_INTERNAL
sunxi_pwm_pin_set_state, fdt_set_all_pin, ret=-1
[07.410]LCD open finish
on fb failed !-1
[07.416][mmc]: delete mmc-hs400-1_8v from dtb
[07.420][mmc]: delete mmc-hs200-1_8v from dtb
[07.424][mmc]: get max-frequency ok 50000000 Hz
[07.432]update dts
** Unrecognized filesystem type **
[07.443]load file(ULI/factory/snum.txt) error.
** Unrecognized filesystem type **
[07.457]load file(ULI/factory/mac.txt) error.
** Unrecognized filesystem type **
[07.470]load file(ULI/factory/wifi_mac.txt) error.
** Unrecognized filesystem type **
[07.484]load file(ULI/factory/bt_mac.txt) error.
** Unrecognized filesystem type **
[07.498]load file(ULI/factory/specialstr.txt) error.
[07.509]update part info
[07.536]bootmode[2]:0x5f
[07.538]update bootcmd
Hit any key to stop autoboot:  0
sunxi_fastboot_init
recv addr 0x41000000
send addr 0x7bf3e240
start to display fastbootlogo.bmp
[07.559]bmp_name=fastbootlogo.bmp
189966 bytes read in 3 ms (60.4 MiB/s)
delay time 0
weak:otg_phy_config
usb init ok
sunxi_usb_fastboot_status=0
set address 0x19
set address 0x19 ok

离线

#1 2021-10-14 10:12:24

哇酷小二
管理员
注册时间: 2020-04-22
已发帖子: 2,638
积分: 1902

Re: A133芯片,配置龙芯Lt8911exb 问题

[01.338]workmode = 0,storage type = 2
[01.342][mmc]: mmc driver ver uboot2018:2020-5-25 9:26:00-202007011433
[01.349][mmc]: get sdc_type fail and use default host:tm4.
[01.361][mmc]: SUNXI SDMMC Controller Version:0x50300
[01.384][mmc]: Best spd md: 2-HSDDR52/DDR50, freq: 2-50000000, Bus width: 8
[01.391]sunxi flash init ok
[01.395]Loading Environment from SUNXI_FLASH... OK
[01.413]Item0 (Map) magic is bad
[01.415]the secure storage item0 copy0 magic is bad
[01.430]Item0 (Map) magic is bad
[01.432]the secure storage item0 copy1 magic is bad
[01.437]Item0 (Map) magic is bad
secure storage read widevine fail
[01.443]secure storage read widevine fail with:-1
secure storage read ec_key fail
[01.450]secure storage read ec_key fail with:-1
[01.456]usb burn from boot

找一个能正常的工作的固件,烧进去,判断是软件问题,还是硬件问题。

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn