您尚未登录。

楼主 # 2022-09-16 09:23:52

superhe
会员
注册时间: 2022-01-01
已发帖子: 9
积分: 40

请教V3S以太网能出eth0但无法得到IP的问题

编译出相同的固件,TF卡启动,在Licheepi Zero板子上能出IP,ping www.baidu.com 能成功(说明应该不是软件问题);但TF卡插在自己做的板子上,能识别eth0,但无法出IP。在自己的板子上 LCD、USB HUB都正常,就eth0不能出IP,请大佬帮忙看下可能是什么原因呢?

ETH网只和EPHY-VCC、EPHY-RTX、EPHY-TXP、EPHY-TXN、EPHY-RXP、EPHY-RXN、EPHY-VDD这几个脚有关吧?

目前硬件接法:

EPHY-VCC是3.3V
EPHY-VDD是1.2V
EPHY-RTX是6K电阻到地
EPHY-TXP接HR911105A的1脚
EPHY-TXN接HR911105A的2脚
EPHY-RXP接HR911105A的3脚
EPHY-RXN接HR911105A的6脚
HR911105A的4、5脚分别100NF电容到地
HR911105A的13脚1M电阻到地以及1NF电容到地

离线

#1 2022-09-16 15:54:04

lovehex99
会员
注册时间: 2022-08-15
已发帖子: 5
积分: 0

Re: 请教V3S以太网能出eth0但无法得到IP的问题

硬件问题? 量下讯号吧

离线

楼主 #2 2022-09-16 17:59:48

superhe
会员
注册时间: 2022-01-01
已发帖子: 9
积分: 40

Re: 请教V3S以太网能出eth0但无法得到IP的问题

请问主要是量哪几个指标呢?我量了电压是正确的。 其它都是芯片内部输入输出的

最近编辑记录 superhe (2022-09-16 18:00:34)

离线

楼主 #3 2022-09-17 23:08:34

superhe
会员
注册时间: 2022-01-01
已发帖子: 9
积分: 40

Re: 请教V3S以太网能出eth0但无法得到IP的问题

后来又试了多次,偶尔一次系统重启后可以出IP,绝大部分次数不能出IP,能出IP的次数还能正常上网(不能出IP的数次,如果人工用 ifconfig eth0 192.168.xx.xx指定IP和路由,ping 不通,也不能上网)。只要有的次数网络能正常,就表明各引脚线序应该没有问题。能出IP的次RJ45灯会灭,不能出IP的次RJ45灯一直常灯。
能出IP的次,只要不拔网线,网络就能一直正常工作,由此证明不是网线松动或者某项指标不稳的原因。
能出IP的次,如果把网线拔了,会出现“... Link is down ...”的提示,但如果拔掉网线后再把网线插上,不会出现“... Link is up ...”的提示,拔了再插网络就又不能用了
种种迹象表明,可能网络能用与不能用,不是和硬件的某个常态相关,而是和某个初始化时机的状态相关, 有没有哪位大侠知道,这个所谓的“初始化时机相关”到底是哪一个因素?也没有看到与ETH相关的专门复位控制脚

最近编辑记录 superhe (2022-09-17 23:11:09)

离线

楼主 #4 2022-09-17 23:33:54

superhe
会员
注册时间: 2022-01-01
已发帖子: 9
积分: 40

Re: 请教V3S以太网能出eth0但无法得到IP的问题

还发现了一个规律,同一张卡,在Licheepi Zero上用,启动时不会出现“random: crng init done”的提示,在我自己焊接的板子上,基本上都会出现“random: crng init done”的提示,在我自己焊接的板子上不出现“random: crng init done”的次数,eth0就能出IP。不知道是和硬件哪个地方相关

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn