您尚未登录。

楼主 # 2022-09-16 18:50:14

chopin1998@gmail.com
会员
注册时间: 2022-08-12
已发帖子: 3
积分: 18

有没有用linux开发环境的朋友?

工具链打通了吗

离线

#1 2022-09-16 22:27:28

Ray
会员
注册时间: 2019-09-24
已发帖子: 7
积分: 7

Re: 有没有用linux开发环境的朋友?

MounRiver有Linux版本

离线

#2 2022-10-13 17:15:04

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

Arch Linux 有我打包的 mounriver-studio 社区版 https://aur.archlinux.org/packages/mounriver-studio-community-bin
mounriver-studio-toolchain :https://aur.archlinux.org/pkgbase/mounriver-studio-toolchain-bin
rust 版本的 wchisp 工具: https://aur.archlinux.org/packages/wchisp

其他 Linux 完全可以参考 PKGBUILD 内容进行相应的打包。deb 包可以到 ATZLinux (铜豌豆 Linux)gitee 那边仓库提打包请求。附上我这边的链接,负责人看到后会处理的

最近编辑记录 taotieren (2022-10-13 17:17:18)

离线

#3 2022-10-13 19:54:41

support_gxchip
Moderator
注册时间: 2022-07-26
已发帖子: 58
积分: 103

Re: 有没有用linux开发环境的朋友?

厉害,感谢

离线

#4 2022-10-14 09:19:49

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

support_gxchip 说:

厉害,感谢

话说你们还提供 Linux 版本的工具支持吗?

离线

#5 2022-10-14 19:51:21

support_gxchip
Moderator
注册时间: 2022-07-26
已发帖子: 58
积分: 103

Re: 有没有用linux开发环境的朋友?

我们软件是兼职的,很难照顾到,但是我们是开源的,应该可以移植

离线

#6 2022-10-15 16:58:07

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

support_gxchip 说:

我们软件是兼职的,很难照顾到,但是我们是开源的,应该可以移植

反馈的问题,希望能及时处理下:https://gitee.com/gxchip/GX_ISPTool/issues/I5JY5K

离线

#7 2022-10-15 18:34:19

海石生风
会员
所在地: 深圳
注册时间: 2019-07-02
已发帖子: 566
积分: 691
个人网站

Re: 有没有用linux开发环境的朋友?

support_gxchip 说:

我们软件是兼职的,很难照顾到,但是我们是开源的,应该可以移植

我试了下,编译时找不到一个头文件,似乎是系统相关的头文件,不支持跨平台。

../GX_CodeGen/mainwindow.cpp:7:10: fatal error: direct.h: No such file or directory
    7 | #include <direct.h>

离线

#8 2022-10-16 14:43:07

support_gxchip
Moderator
注册时间: 2022-07-26
已发帖子: 58
积分: 103

Re: 有没有用linux开发环境的朋友?

已经反馈给软件了。等等看把

离线

#9 2022-10-17 10:59:44

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

@海石生风
我这边在 Arch 下编译没有这种提示,你这边有添加 qt5-tools 依赖吗?

离线

#10 2022-10-17 20:52:53

海石生风
会员
所在地: 深圳
注册时间: 2019-07-02
已发帖子: 566
积分: 691
个人网站

Re: 有没有用linux开发环境的朋友?

taotieren 说:

@海石生风
我这边在 Arch 下编译没有这种提示,你这边有添加 qt5-tools 依赖吗?

qt5-tools已经安装了:

$ pacman -Ss qt5-tools
extra/qt5-tools 5.15.6+kde+r1-1 (qt qt5) [已安装]
    A cross-platform application and UI framework (Development Tools, QtHelp)

可以用pacman -Qo 看下这个头文件是哪个包提供的吗?

离线

#11 2024-04-10 11:16:23

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

@海石生风 已提 PR 进行修复 https://gitee.com/gxchip/GX_ISPTool/pulls/4
管理员有空的话可以合并下这个 PR

离线

#12 2024-04-10 11:17:18

taotieren
会员
注册时间: 2020-05-19
已发帖子: 116
积分: 151

Re: 有没有用linux开发环境的朋友?

support_gxchip 说:

厉害,感谢

这个 PR 没什么问题的话合并一下吧
https://gitee.com/gxchip/GX_ISPTool/pulls/4
Arch 那边已经可以用了

离线

#13 2024-07-09 09:45:37

9crk
会员
注册时间: 2019-01-24
已发帖子: 5
积分: 5

Re: 有没有用linux开发环境的朋友?

为何需要directX ?

离线

页脚

工信部备案:粤ICP备20025096号 Powered by FluxBB

感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn